Salt la continut


Fotografie

Am probleme cu usb


  • Te rog sa te conectezi pentru a raspunde
9 replici la acest subiect

#1 cris_rover

cris_rover

    Boboc

  • Members
  • Strica
  • 6 mesaje

Scris 06 December 2007 - 03:31 PM

Buna ziua. Problema mea este urmatoarea: am Windows XP Professional SP2 instalat, si am USB 1.1 pe placa de baza. Camera digitala care nu mai merge este un Canon Powershot A430. Cand conectam camera Windowsul pornea o fereastra Explorer cu care imi puteam copia pozele si filmele pe Hdd. Problema era ca nu o puteam vedea ca drive separat, ci numai in fereastra respectiva. Atunci, am incercat, crezand ca este o problema de drivere sa dezinstalez camera si sa o instalez din nou, cautand ceva drivere pe internet. Si m-am apucat si am sters de pe unde am putut tot ceea ce tinea de aceasta camera (din regisry, din program files... in general pe oriunde am vazut ceva). De atunci, cand o conectez windows o vede ca digital still camera (inainte o vedea bine, Canon Powershot A430), si nu mai vrea sa porneasca fereastra respectiva.... deci nu o mai vad deloc! Daca stie cineva cam ce as putea sa fac (fara reinstalare de Windows) va rog sa ma ajutati. PS. Orice alt device conectez la USB functioneaza corect. (am incercat cu multe chestii, mp3 player, alte camere, orice altceva functioneaza.) Multumesc.
  • 0

#2 argv

argv

    Wanderer

  • Silver Member
  • StricaStricaStricaStricaStricaStrica
  • 2715 mesaje

Scris 06 December 2007 - 06:01 PM

incearca sa instalezi driverul ce il aveai inainte
  • 0

#3 cris_rover

cris_rover

    Boboc

  • Members
  • Strica
  • 6 mesaje

Scris 07 December 2007 - 12:35 AM

incearca sa instalezi driverul ce il aveai inainte



Inainte nu am avut nici un driver. Am conectat camera prima data cand am cumparat-o la calculator, si windows a recunoscut-o singur. Nu a trebuit sa instalez nimic. Asta este problema, ca acum nu mai vrea sa o recunoasca.
  • 0

#4 EmmaD

EmmaD

    Orhidee

  • Advanced Member
  • StricaStricaStricaStricaStricaStrica
  • 1700 mesaje

Scris 07 December 2007 - 12:51 AM

Cand conectezi camera la PC, verifica daca in Device Manager ai cumva vreo eroare. Normal ar trebui sa apara in Other Devices. Da de acolo un uninstall, apoi Scan for hardware changes, pune CD-ul cu XP in unitatea optica si lasa-l sa scaneze. Din cate stiu eu XP-ul stie ce-i ala Canon, ar trebui sa stie si sa repare ceea ce ai sters tu.

Ca solutie mult mai rapida, un System Restore ar rezolva problema, cu conditia sa setezi un Restore Point anterior datei la care ai facut modificarile despre care ai vorbit mai sus.
  • 0

#5 cris_rover

cris_rover

    Boboc

  • Members
  • Strica
  • 6 mesaje

Scris 07 December 2007 - 01:53 AM

Cand conectezi camera la PC, verifica daca in Device Manager ai cumva vreo eroare. Normal ar trebui sa apara in Other Devices. Da de acolo un uninstall, apoi Scan for hardware changes, pune CD-ul cu XP in unitatea optica si lasa-l sa scaneze. Din cate stiu eu XP-ul stie ce-i ala Canon, ar trebui sa stie si sa repare ceea ce ai sters tu.

Ca solutie mult mai rapida, un System Restore ar rezolva problema, cu conditia sa setezi un Restore Point anterior datei la care ai facut modificarile despre care ai vorbit mai sus.



Este foarte complicata problema mea. Am gasit acum ceva pe net de la microsoft tech, un raspuns pentru cineva cu o problema asemanatoare cu a mea, si am reusit sa sterg definitiv si complet tot ce era aiurea in dev manager, si in registry, si in directorul inf al windows-ului.. Dupa aceea..... same shit. Iar o vede in dev manager ca Digital still camera. Si cat despre sys restore.... l-am dezactivat in ziua cand am instalat windows (acum 3 ani...). Si de atunci numai acum as avea nevoie...


Si am mai observat ceva chiar acum... poate este relevant.. : daca intru in Control Panel/Scanner and cameras/add new device: Nu merge. Nu porneste.

Aceast mesaj a fost editat de cris_rover: 07 December 2007 - 02:22 AM

  • 0

#6 argv

argv

    Wanderer

  • Silver Member
  • StricaStricaStricaStricaStricaStrica
  • 2715 mesaje

Scris 07 December 2007 - 10:10 AM

Cum se numesc driverele care le-ai instalat? Am facut download de pe site de la cannon la driverul pentru win2000 (pentru winxp nu propun); incearca sa-l instalezi, din cate-mi amintesc nu erau schimbari majore la drivere intre cele doua sisteme, asa ca ar trebui sa merga. Uite aici fisierul:

k6404mux.exe

Aceast mesaj a fost editat de Argv: 07 December 2007 - 10:10 AM

  • 0

#7 cris_rover

cris_rover

    Boboc

  • Members
  • Strica
  • 6 mesaje

Scris 07 December 2007 - 06:40 PM

Cum se numesc driverele care le-ai instalat? Am facut download de pe site de la cannon la driverul pentru win2000 (pentru winxp nu propun); incearca sa-l instalezi, din cate-mi amintesc nu erau schimbari majore la drivere intre cele doua sisteme, asa ca ar trebui sa merga. Uite aici fisierul:

k6404mux.exe


Mersi mult, dar... inca tot nu merge. Am incercat cu driverul asta de la tine si imi da eroarea: Twain driver for XP Not Found! si de acolo iese din instalare. Acum trebuie sa vad ce ii cu driverul ala. De ce nu il am, si de unde sa-l iau jos. Mai incerc..... PS. Nu am apucat sa instalez drivere noi, atunci cand m-o apucat sa fac asta... pentru ca de fapt pe cd NU sunt drivere... Da eu nu m-am uitat, si ata e. Camera e facuta in XP sa o vada singur. Ata e.
  • 0

#8 argv

argv

    Wanderer

  • Silver Member
  • StricaStricaStricaStricaStricaStrica
  • 2715 mesaje

Scris 07 December 2007 - 06:59 PM

Probabil ca mesajul zice ca in exe-ul respectiv nu este driverul pt xp; deci nu prea ai unde cauta. Trebuie identificat driver-ul in kitul de XP; stai sa vad ce am in hidden devices

Am remarcat ca, atunci cand conectez aparatul meu sony, apare in Device Manager/Universal Serial Bus controllers un element Sony DSC care foloseste 2 drivere:
c:\windows\system32\drivers\sonypvu1.sys
c:\windows\system32\drivers\usbstop.sys

Ar trebui sa conectezi aparatul tau la un alt calculator si sa identfici ce drivere foloseste aparatul tau, sa le copiezi si sa cauti in registrii cheile care fac referinta la aceste drivere si sa le importi
  • 0

#9 cris_rover

cris_rover

    Boboc

  • Members
  • Strica
  • 6 mesaje

Scris 07 December 2007 - 10:35 PM

Probabil ca mesajul zice ca in exe-ul respectiv nu este driverul pt xp; deci nu prea ai unde cauta. Trebuie identificat driver-ul in kitul de XP; stai sa vad ce am in hidden devices

Am remarcat ca, atunci cand conectez aparatul meu sony, apare in Device Manager/Universal Serial Bus controllers un element Sony DSC care foloseste 2 drivere:
c:\windows\system32\drivers\sonypvu1.sys
c:\windows\system32\drivers\usbstop.sys

Ar trebui sa conectezi aparatul tau la un alt calculator si sa identfici ce drivere foloseste aparatul tau, sa le copiezi si sa cauti in registrii cheile care fac referinta la aceste drivere si sa le importi

Mersi pentru un sfat bun. O sa incerc maine sa vad ce se intampla.
  • 0

#10 cris_rover

cris_rover

    Boboc

  • Members
  • Strica
  • 6 mesaje

Scris 08 December 2007 - 12:12 AM

M-am uitat acum la ce drivere foloseste Digital Still Camera asta ca mi-o detecteaza windows-ul si fol: usbscan.sys, ptpusb.dll, ptpusd.dll.
  • 0